RetouchPRO

Go Back   RetouchPRO > Tools > Software
Register Blogs FAQ Site Nav Search Today's Posts Mark Forums Read


Software Photoshop, Lightroom, Paintshop Pro, Painter, etc., and all their various plugins. Of course, you can also discuss all other programs, as well.

Image Processor + Actions quit working together

Reply
 
Thread Tools
  #1  
Old 03-06-2016, 10:01 PM
frankg frankg is offline
Member
 
Join Date: Nov 2007
Posts: 80
Image Processor + Actions quit working together

I use Bridge with Ps (cs6).
One of the tasks I very regularly perform from Bridge is to batch create Jpegs from raw files.
To do this I highlight the files & go to Tools>Ps>Image Processor - or more often to > Image Processor Pro (A Russel Brown script with added features).

Both Image Processor and Image processor Pro allow you to run an action after re-sizing as per their dialog boxes. Just check the run action box and choose which action.
This running of an action, any action, from within Image processor (or Pro) no longer works.

Now I get an error message:
"sorry, I could not process the following file..."
And refers me to a log which I cannot figure out.
The actions themselves are good & I can also run those actions from within Bridge >Tools> Ps> Batch
And, I can also run the actions if the file/s is already open in Ps.
But not as part of Image Processor (or Pro).

I did have some strange behavior last week and cleaned out all Bridge & Ps preferences. I reset them to defaults, then added History states to 60.

Which other prefs may need to be changed to get this operation working smoothly again? I'm missing something ?

I also ran Russel Browns Just Fix It.jsx script which renews the Pro prefs etc. without success.

Image Processor (or Pro) work fine individually, without the action.
So both Image Processor and the actions do not work in combination

Can anyone help me isolate the problem or setting?

Thanks
Frank
Reply With Quote top
  #2  
Old 03-06-2016, 10:06 PM
klev klev is offline
Senior Member
 
Join Date: Jun 2010
Posts: 1,109
Re: Image Processor + Actions quit working togethe

Quote:
Originally Posted by frankg View Post
Can anyone help me isolate the problem or setting?
I can try. Paste the entire log. I don't know in advance what information is printed to it. It varies by process, and obviously a crash log here won't be the same as a system level crash.

If I had to guess, I would say it's an issue with the way it accepts file paths. I won't answer further questions on that without seeing a log, because I'm still not sure whether I can generate a likely answer.
Reply With Quote top
  #3  
Old 03-06-2016, 10:27 PM
frankg frankg is offline
Member
 
Join Date: Nov 2007
Posts: 80
Re: Image Processor + Actions quit working togethe

Thanks for looking.
The log changes with each new attempt.
This is the latest
I tried to attach it but it isnt an accepted file type. Here it is copy/pasted.
(off to bed, it's late here. Will check back in a.m.)

2016-03-06T21:49:07 - Start TutorialBuilder.jsx
2016-03-06T21:49:07 - Revision: $Revision: 1.88 $
2016-03-06T21:49:07 - App: Adobe Photoshop
2016-03-06T21:49:07 - App Version: 13.0.6
2016-03-06T21:49:07 - OS: Macintosh OS 10.6.8/64
2016-03-06T21:49:07 - Version: 2.3.1
2016-03-06T21:49:23 - ImageProcessor.run()
2016-03-06T21:49:23 - <ImageProcessorProSettings>
<input source="bridge"/>
<output path="same" subfolder="true" keepStructure="false"/>
<taskList>
<task enabled="true" subfolderName="jpeg" colorProfile="sRGB IEC61966-2.1">
<saveOptions fileSaveType="jpg" jpgQuality="10" jpgEmbedColorProfile="true" jpgFormat="Optimized" jpgConvertToSRGB="false" saveForWeb="true"/>
<resizeOptions enabled="true" dontEnlarge="false" width="0" widthUnits="pixels" height="720" heightUnits="pixels" resolution="72" resolutionUnits="pixels/inch" scale="true" resampleMethod="bicubicsharper"/>
<action enabled="false" when="After Image Resize" set="Sharpening" name="DisplayOutput_10%"/>
<namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
</task>
<task enabled="false" subfolderName="Set 2" colorProfile="Same as Source">
<saveOptions fileSaveType="tif" tiffByteOrder="MacOS" tiffEncoding="None" tiffEmbedColorProfile="true" flattenImage="false"/>
<resizeOptions enabled="true" dontEnlarge="false" width="1200" widthUnits="pixels" height="1200" heightUnits="pixels" resolution="240" resolutionUnits="pixels/inch" scale="true" resampleMethod="bicubic"/>
<action enabled="false" when="After Image Resize" set="Luminosity Masks" name="Create Luminosity Masks"/>
<namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
</task>
<task enabled="false" subfolderName="Set 3" colorProfile="Same as Source">
<saveOptions fileSaveType="psd" psdAlphaChannels="true" psdEmbedColorProfile="true" psdLayers="true" psdMaximizeCompatibility="true" flattenImage="false"/>
<resizeOptions enabled="false"/>
<action enabled="false" when="After Image Resize" set="Luminosity Masks" name="Create Luminosity Masks"/>
<namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
</task>
</taskList>
<preferences/>
<uiPrefs>
<lastX>540</lastX>
<lastY>271</lastY>
<lastOutputFolder>/Volumes/Photo_files_2/Temp_PhotoFiles_2/Instagram/to_do</lastOutputFolder>
</uiPrefs>
</ImageProcessorProSettings>
2016-03-06T21:49:24 - Processing: 0769.tif
2016-03-06T21:49:24 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/0769.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/0769.jpg
2016-03-06T21:49:25 - Processing: 0926.tif
2016-03-06T21:49:25 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/0926.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/0926.jpg
2016-03-06T21:49:25 - Processing: 0790.tif
2016-03-06T21:49:25 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/0790.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/0790.jpg
2016-03-06T21:49:26 - Processing: _1080018.tif
2016-03-06T21:49:26 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1080018.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1080018.jpg
2016-03-06T21:49:26 - Processing: _1150718.tif
2016-03-06T21:49:26 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1150718.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1150718.jpg
2016-03-06T21:49:26 - Processing: _1150785.tif
2016-03-06T21:49:26 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1150785.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1150785.jpg
2016-03-06T21:49:27 - Processing: _1140905.tif
2016-03-06T21:49:27 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1140905.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1140905.jpg
2016-03-06T21:49:27 - Processing: _1080059.tif
2016-03-06T21:49:27 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1080059.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1080059.jpg
Reply With Quote top
  #4  
Old 03-06-2016, 10:30 PM
frankg frankg is offline
Member
 
Join Date: Nov 2007
Posts: 80
Re: Image Processor + Actions quit working togethe

...and this file is just below the .log file - it's called a .xml file

<?xml version="1.0" encoding="utf-8"?>
<ImageProcessorProSettings>
<input source="bridge"/>
<output path="same" subfolder="true" keepStructure="false"/>
<taskList>
<task enabled="true" subfolderName="jpeg" colorProfile="sRGB IEC61966-2.1">
<saveOptions fileSaveType="jpg" jpgQuality="10" jpgEmbedColorProfile="true" jpgFormat="Optimized" jpgConvertToSRGB="false" saveForWeb="true"/>
<resizeOptions enabled="true" dontEnlarge="false" width="0" widthUnits="pixels" height="720" heightUnits="pixels" resolution="72" resolutionUnits="pixels/inch" scale="true" resampleMethod="bicubicsharper"/>
<action enabled="false" when="After Image Resize" set="Sharpening" name="DisplayOutput_10%"/>
<namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
</task>
<task enabled="false" subfolderName="Set 2" colorProfile="Same as Source">
<saveOptions fileSaveType="tif" tiffByteOrder="MacOS" tiffEncoding="None" tiffEmbedColorProfile="true" flattenImage="false"/>
<resizeOptions enabled="true" dontEnlarge="false" width="1200" widthUnits="pixels" height="1200" heightUnits="pixels" resolution="240" resolutionUnits="pixels/inch" scale="true" resampleMethod="bicubic"/>
<action enabled="false" when="After Image Resize" set="Luminosity Masks" name="Create Luminosity Masks"/>
<namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
</task>
<task enabled="false" subfolderName="Set 3" colorProfile="Same as Source">
<saveOptions fileSaveType="psd" psdAlphaChannels="true" psdEmbedColorProfile="true" psdLayers="true" psdMaximizeCompatibility="true" flattenImage="false"/>
<resizeOptions enabled="false"/>
<action enabled="false" when="After Image Resize" set="Luminosity Masks" name="Create Luminosity Masks"/>
<namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
</task>
</taskList>
<preferences/>
<uiPrefs>
<lastX>540</lastX>
<lastY>271</lastY>
<lastOutputFolder>/Volumes/Photo_files_2/Temp_PhotoFiles_2/Instagram/to_do</lastOutputFolder>
</uiPrefs>
<date>2016-03-06T21:49:23</date>
<version>2.3.1</version>
</ImageProcessorProSettings>
Reply With Quote top
  #5  
Old 03-06-2016, 11:37 PM
klev klev is offline
Senior Member
 
Join Date: Jun 2010
Posts: 1,109
Re: Image Processor + Actions quit working togethe

None of the settings seem all that strange. I'm curious whether there are potential duplicate naming issues though. I can't spot any kind of conflict resolution for them.

I'm saying this because other possibilities look less likely to me. I would suspect a naming conflict. A file permissions issue is also possible, but it's less likely. If you couldn't access a drive after ejecting and later remounting it, I would have considered the possibility of orphaned symbolic links.

It doesn't appear as if your entire application crashed, as it didn't print out an unwound stack or anything of that sort, just a list of settings.
Reply With Quote top
  #6  
Old 03-07-2016, 07:32 AM
frankg frankg is offline
Member
 
Join Date: Nov 2007
Posts: 80
Re: Image Processor + Actions quit working togethe

"suspect a naming conflict. A file permissions issue is also possible"

When I had strange behavior issues, one of the things I did was to run a utility app for mac called 'cocktail'. It repaired permissions, cleared cache & a few other tasks. One of the things it picked up was an indexing issue with spotlight. No idea of the relevance.
Attached Images
File Type: jpg Screen shot 2016-03-07 at 8.23.10 AM.jpg (44.1 KB, 4 views)
Reply With Quote top
  #7  
Old 03-07-2016, 02:48 PM
klev klev is offline
Senior Member
 
Join Date: Jun 2010
Posts: 1,109
Re: Image Processor + Actions quit working togethe

Quote:
Originally Posted by frankg View Post
One of the things it picked up was an indexing issue with spotlight. No idea of the relevance.
That isn't necessarily the same thing. A naming conflict seems like the most likely issue, because it starts off okay. Drive timing out is another possible issue, but that shouldn't actually happen. You could still write to something without a spotlight index as long as you have a valid file path. spotlight just allows you to search contents by indexing them. It's a somewhat higher level utility than the underlying unix commands that actually fetch a file from the correct volume.
Reply With Quote top
  #8  
Old 03-07-2016, 03:24 PM
frankg frankg is offline
Member
 
Join Date: Nov 2007
Posts: 80
Re: Image Processor + Actions quit working togethe

'A naming conflict seems like the most likely issue"

Any idea how to track this down?
Reply With Quote top
  #9  
Old 03-07-2016, 05:00 PM
klev klev is offline
Senior Member
 
Join Date: Jun 2010
Posts: 1,109
Re: Image Processor + Actions quit working togethe

Quote:
Originally Posted by frankg View Post
'A naming conflict seems like the most likely issue"

Any idea how to track this down?
Test on an empty folder. If it's halting to avoid overwrites (entirely possible, it's a single flag on a system level command), that should alleviate it.
Reply With Quote top
  #10  
Old 03-07-2016, 05:50 PM
frankg frankg is offline
Member
 
Join Date: Nov 2007
Posts: 80
Re: Image Processor + Actions quit working togethe

I'm not following you. It can't run on an empty folder - there are no files to process.
Reply With Quote top
Reply

  RetouchPRO > Tools > Software


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Seeking advice on retouching headshot (with image) vardman Photo Retouching 6 05-22-2014 12:51 PM
Improving colors/brightness in biology image. hochl Photo Retouching 11 07-04-2012 04:07 PM
need help with text image to make it readable mokylim Image Help 1 10-11-2011 01:50 AM
Composite Image ylwdog Photo Compositing 20 05-05-2011 06:35 AM
adding image straight on P_fuzz Website Feedback 3 01-22-2011 08:54 PM


All times are GMT -6. The time now is 03:02 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Copyright © 2016 Doug Nelson. All Rights Reserved