Announcement

Collapse
No announcement yet.

Did I get a lemon - or am I doing something wrong

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • thomasgeorge
    replied
    You might try/check the following:
    (1) Make sure the paper is inserted in the correct way..printing on the wrong side will cause all kinds of problems.( I've done it many times!) Blotchiness and muddy colors particularly can be caused by this. For the Matte paper the bright side is the correct side to print on..you have to look carefully as it is not always easy to tell the difference.
    (2) Would suggest using the Epson Heavyweight Matte paper only. I have had excellent and consistant results with it.
    (3) Make sure your paper setting in the control panel is the same as the paper you are using.
    (4) Use only Epson Inks. Too much variability with generic/aftermarket types.
    (5) In your control panel check for format..If set to RAW, try switching to EMF..
    Good luck....Tom

    Leave a comment:


  • gland
    replied
    My 1270 has been flawless. Good luck with customer service.

    Leave a comment:


  • winwintoo
    replied
    I'm using Epson ink and Epson paper - maybe I missed a paper setting or something, but it seems that whenever I switch from one paper to another, I have problems. It sure is a tempermental beast!

    I guess my next call will be to Epson support and see if they can suggest anything.

    Margaret

    Leave a comment:


  • Doug Nelson
    replied
    The only trouble I've ever had with my 1270 (older version) and blotchy colors was when I had it set to the wrong paper type. It threw too much ink at the paper.

    I've also heard the Epson printers can have problems printing on plastic or RC papers. There's a thread here somewhere about someone having problems printing on a Kodak paper that was RC.

    Leave a comment:


  • Blacknight
    replied
    Using Epson Ink? I have since I bought mine, and no problems. They bought a new one at work and "saved" money by getting brand x ink for it - it clogs up and has to have the nozzle clean thing run on it for several times before it will work at all.

    Leave a comment:


  • DJ Dubovsky
    replied
    Here are some questions I would check on.
    1. Are you using the correct driver for your set up?
    2. Are you using the correct paper and inks?
    3. Are you making sure your printer is set to the correct paper settings?
    4. Have you gone trough the trouble shooting section in the book?
    5. Have you contacted Epson yet? If all fails seek out support. You paid for it when you bought the machine. Why not get your moneys worth? They can certainly give you the answers for your specific problem.
    Hope that helps.
    DJ

    Leave a comment:


  • winwintoo
    started a topic Did I get a lemon - or am I doing something wrong

    Did I get a lemon - or am I doing something wrong

    I got an Epson 1280 printer about 3 months ago. I had seen the output from someone elses and I was assured that I could use it do produce quality photos for my customers.

    Well, the quality is terrible and I only get about half a dozen prints before I have to run all the tools on it again because the prints are all blotchy etc.

    What is everyone else's experience with this printer? Am I the only one disappointed with the output?

    Margaret
Loading...
Working...
X