Announcement

Collapse
No announcement yet.

"File is locked..." errors when trying "File Save As..." in PS7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "File is locked..." errors when trying "File Save As..." in PS7

    I'm having a bad problem with getting a "File is locked" error at least 50% of the time when I try to do a File/Save As operation in PS7. This is almost always while generating a new file, so there is no duplicate file name in the directory that I'm saving the image in. When I retry the operation it always works fine - it's just highly annoying to have to do this 2x most of the time. Has anyone else had this problem?

    FWIW, my images are usually small (45-200k), and my P4-1.6GHz has 512MB RAM and 10GB free HDD space in the partition where I'm saving.

    Thanx,
    Wm

  • #2
    By any chance are you using the NTFS file system?
    Learn by teaching
    Take responsibility for learning

    Comment


    • #3
      My workstation is Win2k with NTFS (Photoshop is installed here), but the data drive is a Win98 machine (Fat32).

      Wm

      Comment


      • #4
        I just did a quick search at Adobe.com. Didn't get any hits, but it's 5:30 a.m. and I haven't had coffee yet.

        If you haven't considered it, the Win/Photoshop forum there might be a good place to start a thread on this one. Adobe developers + a LOT of tech heavyweights frequent that forum. Include a lot of tech detail if you go that route.

        Any particular reason why you're using "Save As..." on new files vs. plain ol' "Save"? Results should be the same, but I'm curious.

        Comment


        • #5
          "Save As" allows me to specify a different directory (the data drive on the Win98 machine) whereas the "Save" will keep the file where it is (email attachments are in a complicated temp path, not easily "findable").

          I'll go look for the Adobe forum - thanx!

          Wm

          Comment


          • #6
            Never a good idea to save files over a network. Save locally, then copy.
            Learn by teaching
            Take responsibility for learning

            Comment


            • #7
              Doug:

              Since his problem appears to be intermittent, is it possible the SAVE AS... "doesn't work" when the Win98 machine is in the middle of "doing whatever" (saving a file? doing an open?) during which access to the drive(s) in question is denied until Win98 finishes?

              Comment


              • #8
                Originally posted by Doug Nelson
                Never a good idea to save files over a network. Save locally, then copy.
                Okay, fill me in. Why is that?

                ed

                Comment


                • #9
                  I don't know the technical reasons, but I do know that saving over a network is a lot less reliable than saving locally. Probably due to so much going on over the network, bits get lost. Adobe agrees with me on this, btw (not about bits getting lost, I was guessing there, but about never saving over a network)
                  Learn by teaching
                  Take responsibility for learning

                  Comment


                  • #10
                    Thanks for the explanation.

                    Ed

                    Comment

                    Related Topics

                    Collapse

                    • dungbeetle
                      Driving me crazy! (about file extensions)
                      by dungbeetle
                      Hi everyone.

                      I've tried everything I can think of to solve this one, but still no luck.

                      I don't know if it's just my machine and/or my installation, but Photoshop 7 (I've tried the original and v 7.0.1) insists on adding a .psd extension to the file every time I try to...
                      08-06-2005, 12:02 PM
                    • Carol Heath
                      Unable to save file as jpeg? Totally baffled
                      by Carol Heath
                      Hi everyone.

                      I am hoping that someone can offer some suggestions. I have finished a restoration and, as always, I have created a lower res, watermarked copy to email to my client for approval. For some reason however, Photoshop (CS2) will not allow me to save the file as a jpeg. The...
                      01-18-2010, 05:04 PM
                    • KTG
                      No extensions
                      by KTG
                      I have been working with some rather large files, but when I go to Save As
                      and save as a tiff or jpeg it does not add the extension .tif or .jpg.

                      I went into Preferences and I have Append File Extension -----Always
                      and Use Lower Case checked.

                      Another odd...
                      12-04-2012, 02:55 PM
                    • cendres
                      help - compression problem
                      by cendres
                      Hi,
                      I am using photoshop 6.0 and my camera outputs roughly a 2 mg jpg file at a size of 2560 x 1920 based on the settings I use in my camera. Picture quality is set at fine (highest)

                      When I open up a picture in photoshop generally all I need to do is a levels adjustment and I...
                      02-10-2002, 11:43 AM
                    • Howard Smith
                      TIFF file problems
                      by Howard Smith
                       I have been advised to save finished
                      Photoshop work using the lossless tiff file
                      format vis the lossy jpeg file format. But I have
                      a problem opening these tiff files in other
                      applications. My scanner is a Canoscan D
                      660U. The images scanned with this scanner...
                      03-10-2002, 06:10 PM
                    Working...
                    X