Announcement

Collapse
No announcement yet.

cc 2015 record action bug?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Photoshop: cc 2015 record action bug?

    Hi
    i'm running cc 2015.1.1 under w10 pro 64bit

    can somebody please test it and tell me if it's a bug or i should uninstall again and reinstall ps ?

    i have record an action ,with several layers , all selective colors , set to absolute

    i record these
    1) reds->black -100 , yellow +100 , green +100,cyan +100 , blues +100 , magenta +100 , whtite +100 ,neutrals +100 , black +100
    2) reds ->black +100 , yellow -100 , green +100,cyan +100 , blues +100 , magenta +100 , whtite +100 ,neutrals +100 , black +100
    3)reds ->black +100 , yellow +100 , green -100,cyan +100 , blues +100 , magenta +100 , whtite +100 ,neutrals +100 , black +100
    4)reds ->black +100 , yellow +100 , green +100,cyan -100 , blues +100 , magenta +100 , whtite +100 ,neutrals +100 , black +100
    5)reds ->black +100 , yellow +100 , green +100,cyan +100 , blues -100 , magenta +100 , whtite +100 ,neutrals +100 , black +100
    6)reds ->black +100 , yellow +100 , green +100,cyan +100 , blues +100 , magenta -100 , whtite +100 ,neutrals +100 , black +100
    7)reds ->black +100 , yellow +100 , green +100,cyan +100 , blues +100 , magenta +100 , whtite -100 ,neutrals +100 , black +100
    8)reds ->black +100 , yellow +100 , green +100,cyan +100 , blues +100 , magenta +100 , whtite +100 ,neutrals -100 , black +100
    9)reds ->black +100 , yellow +100 , green +100,cyan +100 , blues +100 , magenta +100 , whtite +100 ,neutrals +100 , black -100

    but when i play the action , ps cc 2015.1.1 (even 2015.1 ) create all the layers but set to relative !

    can you please test it?

    thanks

  • #2
    Re: cc 2015 record action bug?

    Hi Mantra
    I suggest you go into the Action and expand each command associated with setting up the Selective Color Adjustment Layers. Most likely you will not see the command to set the adjustment Layer to Absolute.

    From my understanding of how it is being recorded is that it incrementally records any buttons that are changed or sliders that are moved.

    That means if the Absolute Radio button was initially set to relative, and then clicked to me absolute, it is not recorded and what ends up being used in the Action is the last setting of Selective Color whether it was with an Adjustment Layer or from the Image > Adjustments > Selective Color command.

    If I am right in my understanding, that is a crazy way to Adobe to record the action in my opinion.

    The way to override it not being recorded, is to make sure that while recording either:
    a) If relative is set, then click on absolute (this will record an action)
    b) if already set to absolute, the click on relative followed by clicking on absolute. This will force the action to record the Action correctly.

    Hope this helps some.

    Comment


    • #3
      Re: cc 2015 record action bug?

      Originally posted by John Wheeler View Post
      Hi Mantra
      I suggest you go into the Action and expand each command associated with setting up the Selective Color Adjustment Layers. Most likely you will not see the command to set the adjustment Layer to Absolute.
      Hi John
      did you try to record this action with cc 2015 ?

      I suggest you go into the Action and expand each command associated with setting up the Selective Color Adjustment Layers
      in the action i can see make adjustament layer it ends with....3 more
      right there is not way to see absolute or relative


      The way to override it not being recorded, is to make sure that while recording either:
      a) If relative is set, then click on absolute (this will record an action)
      b) if already set to absolute, the click on relative followed by clicking on absolute. This will force the action to record the Action correctly.
      may i know what should i do exactly ?
      play the action and after start to record and set all of them to absolute?

      thanks John very very kind

      really may i know if you tried with cc 2015 ?
      because for adobe , photoshop cc 2015 does record the action perfectly

      Comment


      • #4
        Re: cc 2015 record action bug?

        Hi Mantra

        You're welcome.

        Yes I did record an Action with Photoshop CC 2015.0.1 and I am using a Mac with OSX 10.10.5

        To answer your question more specifically on what to do, it would be best to see you Action file directly. I am assuming that you have recorded the Action in PS CC 2015 and when played in PS CC 2015 it creates Selective Adjustment Layers set to relative when you were expecting them all to be set to Absolute.

        I suggest you Save the Action Set in which the Action is located. It will be save as an ATN file at the location of your choice. The Zip the file in Windows 10 (instructions here: http://www.laptopmag.com/articles/ho...les-windows-10 )

        You can attach the zip file to a foum posting and I will then be able to download that file and load it into my Actions in PS CC 2015.

        I believe this will be the most efficient way to proceed for the next steps.

        PS - If you have not saved an Action before, this link will help with that step as well: https://helpx.adobe.com/photoshop/us...g-actions.html

        Comment


        • #5
          Re: cc 2015 record action bug?

          Originally posted by John Wheeler View Post
          Hi Mantra

          You're welcome.

          Yes I did record an Action with Photoshop CC 2015.0.1 and I am using a Mac with OSX 10.10.5

          To answer your question more specifically on what to do, it would be best to see you Action file directly. I am assuming that you have recorded the Action in PS CC 2015 and when played in PS CC 2015 it creates Selective Adjustment Layers set to relative when you were expecting them all to be set to Absolute.

          I suggest you Save the Action Set in which the Action is located. It will be save as an ATN file at the location of your choice. The Zip the file in Windows 10 (instructions here: http://www.laptopmag.com/articles/ho...les-windows-10 )

          You can attach the zip file to a foum posting and I will then be able to download that file and load it into my Actions in PS CC 2015.

          I believe this will be the most efficient way to proceed for the next steps.

          PS - If you have not saved an Action before, this link will help with that step as well: https://helpx.adobe.com/photoshop/us...g-actions.html
          hi John
          here the action
          may i know if under osx photoshop (record action )does have the same behavior ?
          thanks a lot John
          sorry for my poor english
          Attached Files
          Last edited by mantra; 12-17-2015, 09:42 AM.

          Comment


          • #6
            Re: cc 2015 record action bug?

            Hi Mantra
            No need to excuse yourself for English as it would be better than any second language from me (I use google translate)
            Chiedo scusa per la mia povera italiana.

            As I suspected there is not steps in the Action which sets it to "absolute". I just went to each step and added that action step and saved and zipped the file and attached it below. Please unzip, load these action into your Photoshop and see if this works for you.

            Maschere di saturazione absolute added.atn.zip

            Hope that works for you.

            Comment


            • #7
              Re: cc 2015 record action bug?

              Originally posted by John Wheeler View Post
              Hi Mantra
              No need to excuse yourself for English as it would be better than any second language from me (I use google translate)
              Chiedo scusa per la mia povera italiana.

              As I suspected there is not steps in the Action which sets it to "absolute". I just went to each step and added that action step and saved and zipped the file and attached it below. Please unzip, load these action into your Photoshop and see if this works for you.

              [ATTACH]95478[/ATTACH]

              Hope that works for you.
              Hi John
              it works Perfectly !
              maybe i understood cc 2015 action recorder , after creating all the layer , i should re-open and re-set to absolute ...

              but it weird that cc 2015.1.1 under windows doesn't record the color selective settings included absolute or relative , hope under Mac with OSX 10.10.5 it's different



              John , may i ask a question ? it's offtopic , but is there a way to convert an action to script (that works with 2015 )? http://www.tonton-pixel.com/blog/scr...-actions-file/ but seems to work better under osx


              thanks again !
              1000 times better then adobe support

              Comment


              • #8
                Re: cc 2015 record action bug?

                Hi Mantra
                It is no better on the Mac system for recording Selective Color Adjustment Layer. My best guess is that to make actions run faster, they decided only to record the actual changes made on an adjustment Layer and not the status of every setting. Unfortunately, when using an Action, it starts as default in relative mode and must be changed to absolute. When doing it manually, the absolute button can remain checked when creating subsequent Selective Color Adjustment Layers. I do consider that a bug or at the very least poor software practice by Adobe. I think it is the same issue on prior versions too.

                Glad that the new action worked for you

                Comment


                • #9
                  Re: cc 2015 record action bug?

                  Originally posted by John Wheeler View Post
                  Hi Mantra
                  It is no better on the Mac system for recording Selective Color Adjustment Layer. My best guess is that to make actions run faster, they decided only to record the actual changes made on an adjustment Layer and not the status of every setting. Unfortunately, when using an Action, it starts as default in relative mode and must be changed to absolute. When doing it manually, the absolute button can remain checked when creating subsequent Selective Color Adjustment Layers. I do consider that a bug or at the very least poor software practice by Adobe. I think it is the same issue on prior versions too.

                  Glad that the new action worked for you
                  thanks again John
                  i should pay this forum , because for adobe is perfects ,and they can not replicate that the action does miss absolute setting!
                  i report several other bugs nothing
                  they fixed only the liquify 16bit

                  sometime i 'm thinking to go back and install 2014 , stable
                  cheers have a nice day/night

                  Comment


                  • #10
                    Re: cc 2015 record action bug?

                    You're welcome Mantra. Happy Holidays

                    Comment


                    • #11
                      Re: cc 2015 record action bug?

                      Originally posted by John Wheeler View Post
                      You're welcome Mantra. Happy Holidays
                      hi , in advance , Merry Christmas to you and you loved ones too !

                      Comment


                      • #12
                        Re: cc 2015 record action bug?

                        How does that work? Am I supposed to have CC to re-set to absolute?

                        Here is my action with the same problem: https://www.sendspace.com/file/8kmj9q

                        Would someone be so kind to fix it for me?

                        Thanks

                        Comment


                        • #13
                          Re: cc 2015 record action bug?

                          Originally posted by marameo View Post
                          How does that work? Am I supposed to have CC to re-set to absolute?

                          Here is my action with the same problem: https://www.sendspace.com/file/8kmj9q

                          Would someone be so kind to fix it for me?

                          Thanks
                          hi
                          adobe team did say there is no bug (even i sent a video)
                          about the action , re-set to absolute ,is the only way
                          ciao

                          Comment


                          • #14
                            Re: cc 2015 record action bug?

                            How do I re-set to absolute?

                            Comment


                            • #15
                              Re: cc 2015 record action bug?

                              Originally posted by marameo View Post
                              How do I re-set to absolute?
                              hi
                              have you record the first action ?
                              well go down in the action , record again (on the same action) , douple click on the selective adjustament layer and set to absolute

                              try ..
                              cheers

                              Comment

                              Related Topics

                              Collapse

                              • mark pernal
                                Calling one action from another
                                by mark pernal
                                I'm wondering...is there a way to call one action from another?

                                I've seen an example of that, but it involved calling one action from another INSIDE the same SET. What I'm wondering is, is there a way to call an action from a different set?

                                Thanks.
                                05-16-2003, 07:19 AM
                              • Doug Nelson
                                Script or action for 50% guides
                                by Doug Nelson
                                I'm trying to make an action that will apply vertical and horizontal guides at the 50% mark in any image, with no success. The action records the absolute position, not the relative position.

                                Am I just approaching this wrong, or is this something that will require a script?
                                11-06-2003, 06:56 PM
                              • iheartstudios
                                Photoshop Action nightmare... HELP!!
                                by iheartstudios
                                We have an action when we go through it manually we get what we want but when we then run the action as a batch the images come out completely different eg: un-sharp mask is over processed/levels off etc
                                FinalImg_01testaweb is what we got when we went through the action step by step
                                ...
                                11-02-2010, 11:20 AM
                              • cbeam2
                                basic Action help
                                by cbeam2
                                When I run my action the dialog box for Jpg quality comes up and the action pauses till I click OK. What do I need to do for it to save and close. Oh yes I'm running it from the Batch command.

                                chuck
                                12-23-2003, 08:51 PM
                              • ylwdog
                                How to add a pause/stop in action to adjust layer
                                by ylwdog
                                I am creating an action w/ using the high pass filter and would like to pause it to adjust the amount.
                                How do I do that?

                                thx
                                11-29-2011, 07:56 AM
                              Working...
                              X