Announcement

Collapse
No announcement yet.

Image Processor + Actions quit working together

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Photoshop: Image Processor + Actions quit working together

    I use Bridge with Ps (cs6).
    One of the tasks I very regularly perform from Bridge is to batch create Jpegs from raw files.
    To do this I highlight the files & go to Tools>Ps>Image Processor - or more often to > Image Processor Pro (A Russel Brown script with added features).

    Both Image Processor and Image processor Pro allow you to run an action after re-sizing as per their dialog boxes. Just check the run action box and choose which action.
    This running of an action, any action, from within Image processor (or Pro) no longer works.

    Now I get an error message:
    "sorry, I could not process the following file..."
    And refers me to a log which I cannot figure out.
    The actions themselves are good & I can also run those actions from within Bridge >Tools> Ps> Batch
    And, I can also run the actions if the file/s is already open in Ps.
    But not as part of Image Processor (or Pro).

    I did have some strange behavior last week and cleaned out all Bridge & Ps preferences. I reset them to defaults, then added History states to 60.

    Which other prefs may need to be changed to get this operation working smoothly again? I'm missing something ?

    I also ran Russel Browns Just Fix It.jsx script which renews the Pro prefs etc. without success.

    Image Processor (or Pro) work fine individually, without the action.
    So both Image Processor and the actions do not work in combination

    Can anyone help me isolate the problem or setting?

    Thanks
    Frank

  • #2
    Re: Image Processor + Actions quit working togethe

    Originally posted by frankg View Post
    Can anyone help me isolate the problem or setting?
    I can try. Paste the entire log. I don't know in advance what information is printed to it. It varies by process, and obviously a crash log here won't be the same as a system level crash.

    If I had to guess, I would say it's an issue with the way it accepts file paths. I won't answer further questions on that without seeing a log, because I'm still not sure whether I can generate a likely answer.

    Comment


    • #3
      Re: Image Processor + Actions quit working togethe

      Thanks for looking.
      The log changes with each new attempt.
      This is the latest
      I tried to attach it but it isnt an accepted file type. Here it is copy/pasted.
      (off to bed, it's late here. Will check back in a.m.)

      2016-03-06T21:49:07 - Start TutorialBuilder.jsx
      2016-03-06T21:49:07 - Revision: $Revision: 1.88 $
      2016-03-06T21:49:07 - App: Adobe Photoshop
      2016-03-06T21:49:07 - App Version: 13.0.6
      2016-03-06T21:49:07 - OS: Macintosh OS 10.6.8/64
      2016-03-06T21:49:07 - Version: 2.3.1
      2016-03-06T21:49:23 - ImageProcessor.run()
      2016-03-06T21:49:23 - <ImageProcessorProSettings>
      <input source="bridge"/>
      <output path="same" subfolder="true" keepStructure="false"/>
      <taskList>
      <task enabled="true" subfolderName="jpeg" colorProfile="sRGB IEC61966-2.1">
      <saveOptions fileSaveType="jpg" jpgQuality="10" jpgEmbedColorProfile="true" jpgFormat="Optimized" jpgConvertToSRGB="false" saveForWeb="true"/>
      <resizeOptions enabled="true" dontEnlarge="false" width="0" widthUnits="pixels" height="720" heightUnits="pixels" resolution="72" resolutionUnits="pixels/inch" scale="true" resampleMethod="bicubicsharper"/>
      <action enabled="false" when="After Image Resize" set="Sharpening" name="DisplayOutput_10%"/>
      <namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
      </task>
      <task enabled="false" subfolderName="Set 2" colorProfile="Same as Source">
      <saveOptions fileSaveType="tif" tiffByteOrder="MacOS" tiffEncoding="None" tiffEmbedColorProfile="true" flattenImage="false"/>
      <resizeOptions enabled="true" dontEnlarge="false" width="1200" widthUnits="pixels" height="1200" heightUnits="pixels" resolution="240" resolutionUnits="pixels/inch" scale="true" resampleMethod="bicubic"/>
      <action enabled="false" when="After Image Resize" set="Luminosity Masks" name="Create Luminosity Masks"/>
      <namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
      </task>
      <task enabled="false" subfolderName="Set 3" colorProfile="Same as Source">
      <saveOptions fileSaveType="psd" psdAlphaChannels="true" psdEmbedColorProfile="true" psdLayers="true" psdMaximizeCompatibility="true" flattenImage="false"/>
      <resizeOptions enabled="false"/>
      <action enabled="false" when="After Image Resize" set="Luminosity Masks" name="Create Luminosity Masks"/>
      <namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
      </task>
      </taskList>
      <preferences/>
      <uiPrefs>
      <lastX>540</lastX>
      <lastY>271</lastY>
      <lastOutputFolder>/Volumes/Photo_files_2/Temp_PhotoFiles_2/Instagram/to_do</lastOutputFolder>
      </uiPrefs>
      </ImageProcessorProSettings>
      2016-03-06T21:49:24 - Processing: 0769.tif
      2016-03-06T21:49:24 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/0769.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/0769.jpg
      2016-03-06T21:49:25 - Processing: 0926.tif
      2016-03-06T21:49:25 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/0926.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/0926.jpg
      2016-03-06T21:49:25 - Processing: 0790.tif
      2016-03-06T21:49:25 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/0790.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/0790.jpg
      2016-03-06T21:49:26 - Processing: _1080018.tif
      2016-03-06T21:49:26 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1080018.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1080018.jpg
      2016-03-06T21:49:26 - Processing: _1150718.tif
      2016-03-06T21:49:26 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1150718.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1150718.jpg
      2016-03-06T21:49:26 - Processing: _1150785.tif
      2016-03-06T21:49:26 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1150785.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1150785.jpg
      2016-03-06T21:49:27 - Processing: _1140905.tif
      2016-03-06T21:49:27 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1140905.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1140905.jpg
      2016-03-06T21:49:27 - Processing: _1080059.tif
      2016-03-06T21:49:27 - saving /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/_1080059.tif as /Volumes/Photo_files_2/SA_Dec|Jan2015|6/Arta_tifs/jpeg/_1080059.jpg

      Comment


      • #4
        Re: Image Processor + Actions quit working togethe

        ...and this file is just below the .log file - it's called a .xml file

        <?xml version="1.0" encoding="utf-8"?>
        <ImageProcessorProSettings>
        <input source="bridge"/>
        <output path="same" subfolder="true" keepStructure="false"/>
        <taskList>
        <task enabled="true" subfolderName="jpeg" colorProfile="sRGB IEC61966-2.1">
        <saveOptions fileSaveType="jpg" jpgQuality="10" jpgEmbedColorProfile="true" jpgFormat="Optimized" jpgConvertToSRGB="false" saveForWeb="true"/>
        <resizeOptions enabled="true" dontEnlarge="false" width="0" widthUnits="pixels" height="720" heightUnits="pixels" resolution="72" resolutionUnits="pixels/inch" scale="true" resampleMethod="bicubicsharper"/>
        <action enabled="false" when="After Image Resize" set="Sharpening" name="DisplayOutput_10%"/>
        <namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
        </task>
        <task enabled="false" subfolderName="Set 2" colorProfile="Same as Source">
        <saveOptions fileSaveType="tif" tiffByteOrder="MacOS" tiffEncoding="None" tiffEmbedColorProfile="true" flattenImage="false"/>
        <resizeOptions enabled="true" dontEnlarge="false" width="1200" widthUnits="pixels" height="1200" heightUnits="pixels" resolution="240" resolutionUnits="pixels/inch" scale="true" resampleMethod="bicubic"/>
        <action enabled="false" when="After Image Resize" set="Luminosity Masks" name="Create Luminosity Masks"/>
        <namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
        </task>
        <task enabled="false" subfolderName="Set 3" colorProfile="Same as Source">
        <saveOptions fileSaveType="psd" psdAlphaChannels="true" psdEmbedColorProfile="true" psdLayers="true" psdMaximizeCompatibility="true" flattenImage="false"/>
        <resizeOptions enabled="false"/>
        <action enabled="false" when="After Image Resize" set="Luminosity Masks" name="Create Luminosity Masks"/>
        <namingOptions startingSerial="1">Name,lowerCaseExtension</namingOptions>
        </task>
        </taskList>
        <preferences/>
        <uiPrefs>
        <lastX>540</lastX>
        <lastY>271</lastY>
        <lastOutputFolder>/Volumes/Photo_files_2/Temp_PhotoFiles_2/Instagram/to_do</lastOutputFolder>
        </uiPrefs>
        <date>2016-03-06T21:49:23</date>
        <version>2.3.1</version>
        </ImageProcessorProSettings>

        Comment


        • #5
          Re: Image Processor + Actions quit working togethe

          None of the settings seem all that strange. I'm curious whether there are potential duplicate naming issues though. I can't spot any kind of conflict resolution for them.

          I'm saying this because other possibilities look less likely to me. I would suspect a naming conflict. A file permissions issue is also possible, but it's less likely. If you couldn't access a drive after ejecting and later remounting it, I would have considered the possibility of orphaned symbolic links.

          It doesn't appear as if your entire application crashed, as it didn't print out an unwound stack or anything of that sort, just a list of settings.

          Comment


          • #6
            Re: Image Processor + Actions quit working togethe

            "suspect a naming conflict. A file permissions issue is also possible"

            When I had strange behavior issues, one of the things I did was to run a utility app for mac called 'cocktail'. It repaired permissions, cleared cache & a few other tasks. One of the things it picked up was an indexing issue with spotlight. No idea of the relevance.
            Attached Files

            Comment


            • #7
              Re: Image Processor + Actions quit working togethe

              Originally posted by frankg View Post
              One of the things it picked up was an indexing issue with spotlight. No idea of the relevance.
              That isn't necessarily the same thing. A naming conflict seems like the most likely issue, because it starts off okay. Drive timing out is another possible issue, but that shouldn't actually happen. You could still write to something without a spotlight index as long as you have a valid file path. spotlight just allows you to search contents by indexing them. It's a somewhat higher level utility than the underlying unix commands that actually fetch a file from the correct volume.

              Comment


              • #8
                Re: Image Processor + Actions quit working togethe

                'A naming conflict seems like the most likely issue"

                Any idea how to track this down?

                Comment


                • #9
                  Re: Image Processor + Actions quit working togethe

                  Originally posted by frankg View Post
                  'A naming conflict seems like the most likely issue"

                  Any idea how to track this down?
                  Test on an empty folder. If it's halting to avoid overwrites (entirely possible, it's a single flag on a system level command), that should alleviate it.

                  Comment


                  • #10
                    Re: Image Processor + Actions quit working togethe

                    I'm not following you. It can't run on an empty folder - there are no files to process.

                    Comment


                    • #11
                      Re: Image Processor + Actions quit working togethe

                      Originally posted by frankg View Post
                      I'm not following you. It can't run on an empty folder - there are no files to process.
                      Your destination folder should be something other than your source folder if you're going to test that. It's a common reason why scripts break. If it's not something really simple, the script probably requires updates.

                      Comment


                      • #12
                        Re: Image Processor + Actions quit working togethe

                        it doesnt run whether the destination is the same, a sub-folder, orsomewhere else altogether.
                        The script has been removed and re-installed by adobe extension manager. More than once.
                        And since Image Processor and Image Processor Pro are two different scripts with the same issue, I think it's unlikely the scripts need updates.
                        In act as I originally said, they work fine as long as I dont check the run action box. Z
                        Actions and scripts are fine but not together

                        Comment


                        • #13
                          Re: Image Processor + Actions quit working togethe

                          Hmm well possibly no simple fix then. Reinstalling things only fixes problems with settings or permissions and corrupt dependencies.

                          I can try looking into those scripts when I have a large block of free time, but it would be a different week. It only takes a couple minutes to write a response here. It takes much more time to look into something like that. It may not work at all if I can't reproduce it on my end.

                          Comment


                          • #14
                            Re: Image Processor + Actions quit working togethe

                            No problem. Thanks anyway.

                            Comment


                            • #15
                              Re: Image Processor + Actions quit working togethe

                              Originally posted by frankg View Post
                              No problem. Thanks anyway.
                              No problem. I forgot to mention though, you should try something like stackexchange. They have a huge number of users, so it's likely that someone else has run into a similar problem. I wish I could be of more help.

                              Comment

                              Related Topics

                              Collapse

                              • bouloss
                                Action or script to save 2 output files
                                by bouloss
                                Hi , I am been trying to acheive this with actions, ppl been telling me its only possible using scripts .

                                At first ,save for print is a default JPG 12 same size as the PSD. 300dpi
                                the second save is JPEG 8 and I do apply a image scale by only reducing the dpi to 72. which makes...
                                05-13-2006, 02:20 PM
                              • Jon
                                Where did my actions go?
                                by Jon
                                I just created several actions in PS and searched for them using a wildcard *.atn in my PS directory and subdirectories in my C drive and I can find them. Yet they are in PS and function normally. Are all of them embedded somewhere in a single file?
                                09-23-2002, 07:35 AM
                              • Ed Turlington
                                Actions--Do, or Do Not add SAVE AS step at end?
                                by Ed Turlington
                                On most of the actions I recorded myself I put Save As and Close steps at the end.

                                None of the actions I have purchased have these steps.

                                Can someone simplify the world of complexity around the pros/cons as it relates to "File/Automate/Batch" (apparently (???) if...
                                05-24-2009, 11:23 AM
                              • Brian2
                                Batch actions
                                by Brian2
                                Hope someone can help me with this.

                                I want to make some changes to several photos. They were all taken under the same light, so I want to make the same changes to every photo (levels, contrast, saturation). Is there some batch action in PS CS2 that allows me to automate this process?...
                                11-07-2006, 06:00 AM
                              • daddyo
                                Using PS6 to create actions for use in PE2
                                by daddyo
                                It has been suggested at this site that I may use a downloaded trial of PS6 to create an aciton for use in PE2. However, I have noticed that at the download sites, they all say that the "save" function in PS6 is disabled. How then can one save an action that I have created in this trial version?...
                                10-20-2005, 02:38 PM
                              Working...
                              X