Announcement

Collapse
No announcement yet.

Mend Tool - Patron Info button error.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mend Tool - Patron Info button error.

    I have just received and installed the Mend Tool. I gather that the installation was a success because the Mend options now appear in the Effects pallette.

    When I go into the Effects pallette and double-click Patron Info, nothing happens. I am under the impression that a new image should open and display the basics of the license agreement and contact information for the registered user and the tool creator. The Readme file states that this information will be used for the purpose of forwarding updates and other information; stuff I want to be sure I'll get.

    If I open a new image and then double-click the Patron Info button in the Effects pallette, a new layer will appear, but then I get an error message stating, "Could not complete the command because of a program error."

    I have tried exiting PSE2 and restarting, primarily because it was something I could try quickly, but it didn't change anything.

    This apparent flaw may not impact the operation of the Mend Tool, but I would just as soon it worked properly.

    Does this situation sound familiar to anyone? Thank you.

  • #2
    it has to do with the font, I am sure. The first thing you mention is a bug in Elements...you can't run an action without first opening an image. The second issue is the font issue. I selected Arial Bold. If you install this font, I am sure the patron action will work. You will still be able to receive updates as I can get the information I need whether it works or not. Regretfully the program errors off where it should just select another font. and I can't record the action without the font face reference. As far as i know, this font is included with OS X and Windows XP. Are you missing Arial?

    PS - this does not effect the working of the tool what-so-ever.

    Comment


    • #3
      Thank you for your reply. It happens that Arial is my favorite font and I use it literally all of the time (I have it set as default font in Microsoft Word and Excel.)

      I just tried again to get the Patron Info feature to work. I opened a JPG image and created a new layer, then selected the type tool and set it up for Arial Bold. I then Opened the Layers Palette and double-clicked the Patron Info button. I have thus established that PSE2 has access to the Arial font.

      Program response was identical to my initial report.

      I don't want to take up your time with something that doesn't affect the functioning of the Mend Tool because we're getting into the territory of the Law of Diminishing Returns, but I will keep playing around with it and, possibly, learn something.

      If you have any other suggestions, I would be pleased to hear them. Thanks again for your input!

      Comment


      • #4
        Just tested it here, and it works. you might try dropping that on the unstuff utility again and see if that helps. I can't be sure why there would be a problem, except for those already stated. You might try forwarding me the file -- as you say, it may end up mattering not at all. Let me know if a second unstuff does it.

        Richard

        Comment


        • #5
          Thank you for your reply - I see by the time stamp on your message that you put in a very long day - it is appreciated.

          I did go back through the motions of unpacking and installing the Mend Tool, performance remains the same, however an Alert Flag has just gone up in what passes for my brain. Having printed-out and bound your Readme file (The Hidden Power Mend Tool v. 1.0 Release Notes), I note the following discrepancies: The attached tool file is named Mend+.zip (size: 22kB) rather than Mend.zip. The file (after unzipping with Winzip) contains 6 files as follows: .DS_Store, Mend.atn, Mend.psd, Mend_Setup.atn, Patron_Info.atn, Readme.html. I did not find a folder named Mend, so I created one and placed it in C:\Program Files\Adobe\Photoshop Elements 2\Previews\Effects. I then deleted the Previews Cache as instructed.

          What raises the Alert Flag is this:
          File name slightly different than documentation (the "+" sign).
          No Mend folder included, as indicated by documentation.
          .DS_Store file not mentioned in documentation.

          Lastly - and this is really grasping at straws - you mentioned "unstuffing" the zip file; is "unstuffing" a MAC term? Could I be trying to make a MAC tool work on a PC? Would that make sense in the context of what I see happening in the program? It nows occurs to me that I do not remember specifying which platform I am running (Windows 98SE on a 6-year old Dell).

          Is there a clue in all of the foregoing? Thanks again for your help.

          Comment


          • #6
            I assume, first, that the tool is working? Have you applied it to images and gotten results?

            The Patron action is essentially an information file. It is NOT important to the function of the tool. However, if, in the future, you need support and don't have the file and I have no record of your order (I keep records...and copies of the personalized files, so this is not likely), then I MIGHT ask for you to forward the file. It isn't really worth putting a lot of effort into. it is actually there to make my job of tracking and managing purchases easier, and can be a 'proof-of-purchase'. That I put in the link to the action so you can see your own information was a throw-in...you already know who you are ;-). There are several tracking methods in place beside this to help me help you protect your investment in the tool.

            The 'flags' you have noted are not at all problems. Apparently my email client adds a "+" to the end of the file (perhaps to denote that more than one is attached), and stores directory information in a DS file. Neither of these things is a problem. Discarding the DS file will likely result in...nothing. Whether the file gets stuffed or zipped is nearly inconsequential these days...most utilities I have found handle both. While I have the option of doing either, I make a habit of ZIPing files -- from mac or PC. The internet is not as 'standard' as some would like to believe, and while it is convenient, there may be little differences between how email clients handle the file(s). This is usually not a huge problem.

            Finally, I work fluently on Mac and PC...in fact I sometimes have to pause to remember what OS i am on. Adobe products are bi-platform, and Actions can be swapped between Mac and PC. I make a habit of creating products that are biplatform because I use both platforms -- and am essentially opposed to OS wars. There are no worries about trying to run a Mac tool on a PC -- at least in this case. The tool is designed to work on both. If you are having difficulty, it may have to do with a number of things, not the least of which is buggy behaviors in Elements itself. As I have been able to get this to work on both, I can't be exactly sure what to look at. If it hadn't worked, I'd not have distributed it.

            If the tool is otherwise working (that is the functional setup and mend parts), and the patron thing is upsetting you, please do the following:

            1. Open the Mend.psd in Elements.
            2. Delete the Patron layer from the layers palette.
            3. Save the file.
            4. Delete the Effects cache.
            5. Restart Elements.

            This will remove the Patron effect from the menu. Please do not discard the Patron.atn -- it is harmless and takes up very little room.

            Please do let me know if the tool itself is working...if you are interested in continuing the investigation and can shed any light, I'd be glad to be involved in attempting to solve the problem. I assume you do not have any non-standard font management? If you would like to forward just that file to me by email (not posted here), I would be glad to take a look at it.

            Comment


            • #7
              Thank you for your reply. I have ascertained that the Mend Tool is working. I opened an image and, following your instructions closely, set up the tool and then applied it. The color and tone layers appeared as advertised and I was able to operate all sliders and see the results on the image. What a nice job it does!

              I do have a program called THE FONT THING installed on my PC, but it is not organizing fonts in any way. I occasionally use it to get a screen display of a special font, since it lists them all and shows what they look like.

              It is interesting to learn that there are programs which run on both Mac and PC platforms. I not only didn't know that - I didn't even suspect it.

              I wouldn't characterize the Patron_Info thing as upsetting... more like it is in the nature of a burr on a tooth - you know how your tongue keeps wandering back to it and testing it? That's how I am when I have something on the computer I can't quite get my mind around.

              I think I will send you the Mend file I got by email; perhaps you will see something I don't know to look for.

              I thank you for the time you have invested in this investigation.

              Comment

              Loading...
              Working...
              X